MrDeepFakes Forums
  • New and improved dark forum theme!
  • Guests can now comment on videos on the tube.
   
  • 1(current)
  • 2
  • 3
  • 4
  • 5
  • ...
  • 14
  • Next 
dpfksDeepFaceLab 2.0 - Discussion, tips, suggestions
#1
DeepFaceLab 2.0 - Discussion, tips, suggestions

Older discussion regarding DFL 1.0 can be found here: You are not allowed to view links. Register or Login to view.

DFL 1.0 is no longer supported.

2.0 guide: You are not allowed to view links. Register or Login to view.

Read the official announcement and changes on the github: You are not allowed to view links. Register or Login to view.
~ Fake it till you make it ~
You are not allowed to view links. Register or Login to view.
You are not allowed to view links. Register or Login to view.
#2
Post reserved
~ Fake it till you make it ~
You are not allowed to view links. Register or Login to view.
You are not allowed to view links. Register or Login to view.
#3
First few things for those who will be testing 2.0 DFL: You are not allowed to view links. Register or Login to view.

New spreadsheet for sharing model settings: You are not allowed to view links. Register or Login to view.

- models_opt_on_gpu: False is like optimizer mode 2/3, True is like Optimizer mode 1 (only gpus VRAM utilized)
- sorting methods are all in one .bat file

There are 2 variants of DF and LIAE:

- DFHD/LIAEHD is basically regular DF/LIAE from old SAEHD but better optimized

- DF/LIAE architectures are more like SAE equivalent but with all the features of SAEHD, better optimized, you can expect higher batch sizes than with old SAE or even our modified SAE+.
Raising money for a new GPU, if you enjoy my fakes or my work on forums consider donating via bitcoin, tokens or paypal/patreon, any amount helps!
Paypal/Patreon: You are not allowed to view links. Register or Login to view.
Bitcoin: 1C3dq9zF2DhXKeu969EYmP9UTvHobKKNKF
Want to request a paid deepfake or have any questions reagarding the forums or deepfake creation using DeepFaceLab? Write me a message.
TMB-DF on the main website - You are not allowed to view links. Register or Login to view.
#4
(01-23-2020, 12:22 PM)aymanalz Wrote: You are not allowed to view links. Register or Login to view.Can I still do the merging (ie, converting) on an AMD card, after it was trained on google colab's Nvidia?

AFAIK No.

(01-23-2020, 12:21 PM)blackyou Wrote: You are not allowed to view links. Register or Login to view.Nice work. I'm waiting for colab version. Hehe

You are not allowed to view links. Register or Login to view.

(01-23-2020, 11:08 AM)Hanqaqa Wrote: You are not allowed to view links. Register or Login to view.So happy to try it! Although I still dont know where to download the 2.0 version.

Great job you guys

Don't thank us, thank @iperov unless you want to thank someone for making tutorials and all of that, then sure, you're welcome Wink

Download link is where it always was, on github/google drive, also it's in the 2nd post in this thread.
Raising money for a new GPU, if you enjoy my fakes or my work on forums consider donating via bitcoin, tokens or paypal/patreon, any amount helps!
Paypal/Patreon: You are not allowed to view links. Register or Login to view.
Bitcoin: 1C3dq9zF2DhXKeu969EYmP9UTvHobKKNKF
Want to request a paid deepfake or have any questions reagarding the forums or deepfake creation using DeepFaceLab? Write me a message.
TMB-DF on the main website - You are not allowed to view links. Register or Login to view.
#5
(01-23-2020, 07:02 PM)tutsmybarreh Wrote: You are not allowed to view links. Register or Login to view.You still need compute level 3.5, without it you can only train on CPU.

mininum cc is 3.0
#6
(01-24-2020, 09:32 PM)jknight Wrote: You are not allowed to view links. Register or Login to view.
(01-24-2020, 09:11 PM)tutsmybarreh Wrote: You are not allowed to view links. Register or Login to view.
(01-24-2020, 07:30 PM)jknight Wrote: You are not allowed to view links. Register or Login to view.Getting one OOM after loading models and packs. After that no OOM's. I do however get OOM's and full stop if I turn OFF learn mask. This seems odd as I assume that this would cause less VRAM usage. Anyone else have this issue?


You changed your dims settings, therefore no one will help you, first test your models on default dims and check results, if you feel like the quality isn't as good as you'd want you can try increasing them later.
This requires a lot of testing (to determine impact on quality and how tasking on hardware these changes are).

From my initial tests on 6GB raising 256 to 512 (regular DF) while keeping rest at 64 made me drop batch size by 2 but that was around batch 10-8, if you can run higher batches (or lower) batch required my change by more or less than 2, with DFHD it may be even more of a difference, you also dropped e/d dims and raised d_mask dims too and that makes it even harder to evaluate.

Just run it with default values, also learned mask adds quite a bit to the iteration time and requires lower batch size to run without OOM, test for at least 12 hours, if it doesn't crash after that, then it'll probably run ok. And enable gradient clipping for (insert either fucks or gods) sake unless you don't value your time and like to waste energy by training models that will collapse the second you leave your pc to let it train in the background, it also has an impact on performance and possible batch size but not much, otherwise enable automatic backups.

I understand the lack of support with the modification of dims. I'm just trying to see how far I could push DFL2.0 compared to DFL1.0 at 256res with my card.

I was just curious if anyone has started training with learn_mask True with no OOMS or errors and then switched learned_mask False and having OOMs and full stop when starting training. It just seems like backwards logic to me as I'd expect learn_mask True would require more vram.

And thanks for mentioning clip guard. I guess I forgot to turn it on after mashing the enter key in options.

edit: I am also unable to enable auto backups in options. It just skips it and automatically sets it as no.

On the 1st start yes, but if you then save and start it up again it will let you change which I mentioned in previous posts.
Raising money for a new GPU, if you enjoy my fakes or my work on forums consider donating via bitcoin, tokens or paypal/patreon, any amount helps!
Paypal/Patreon: You are not allowed to view links. Register or Login to view.
Bitcoin: 1C3dq9zF2DhXKeu969EYmP9UTvHobKKNKF
Want to request a paid deepfake or have any questions reagarding the forums or deepfake creation using DeepFaceLab? Write me a message.
TMB-DF on the main website - You are not allowed to view links. Register or Login to view.
#7
Anyone else having trouble with the new h265 mp4 exports? A few issues I've had are that they won't play in Windows, (VLC player works though.) Maybe a codec download will fix that? It's asking for money in Windows. No biggie... 2nd thing is I re-imported the outputted file into Adobe Premiere and it isn't even close to being synced with the audio (However it does play synced in VLC... So maybe it's another codec issue?) And the 3rd thing is weird. I uploaded my outputted video to my google drive like I always do, so I can grab it on my iphone and look at it. I go to the file and save it (I think these are a bit larger than the h264 files) and it says it's downloading to my iPhone. Never ends up in my photo album. Which I've been doing successfully with all previous version of DFL... Plenty of space on my iPhone. Not sure if it's because it doesn't recognize it as a video or if it's something else on my end, but like I said, never happened before. Thanks!

**Edit** Was just looking again in Premiere. It works fine at the beginning of the video. Audio is synced. Around halfway through it seems to glitch and goes off sync majorly. It's a 3 minute video btw.... And again, it does play in VLC player fine. So not sure what's up there.

**Edit 2** Still playing around on my iPhone. Google drive has processed the video now, and I can play it in Google drive. However, I tried again after processing to download it to my phone. It says "downloading" for a decent amount of time and then stops as usual, but again... Nothing in my photo/video album. So weird.
#8
(01-24-2020, 11:56 PM)kilerb Wrote: You are not allowed to view links. Register or Login to view.Anyone else having trouble with the new h265 mp4 exports?  A few issues I've had are that they won't play in Windows, (VLC player works though.)  Maybe a codec download will fix that?  It's asking for money in Windows.  No biggie...  2nd thing is I re-imported the outputted file into Adobe Premiere and it isn't even close to being synced with the audio (However it does play synced in VLC...  So maybe it's another codec issue?)  And the 3rd thing is weird.  I uploaded my outputted video to my google drive like I always do, so I can grab it on my iphone and look at it.  I go to the file and save it (I think these are a bit larger than the h264 files) and it says it's downloading to my iPhone.  Never ends up in my photo album.  Which I've been doing successfully with all previous version of DFL...  Plenty of space on my iPhone.  Not sure if it's because it doesn't recognize it as a video or if it's something else on my end, but like I said, never happened before.  Thanks!

**Edit**  Was just looking again in Premiere.  It works fine at the beginning of the video.  Audio is synced.  Around halfway through it seems to glitch and goes off sync majorly.  It's a 3 minute video btw....  And again, it does play in VLC player fine.  So not sure what's up there.

**Edit 2**  Still playing around on my iPhone.  Google drive has processed the video now, and I can play it in Google drive.  However, I tried again after processing to download it to my phone.  It says "downloading" for a decent amount of time and then stops as usual, but again...  Nothing in my photo/video album.   So weird.

If some site is asking for money for "H265" codec then you are either getting scammed or you got some nice malware on your PC already.

I'll test it later once I train my first fake but not all players can play H265 but most should, same goes for some editing software, it just must be supported.

If you're on PC you can try editing VideoEd file in F:\DF\DFL2.0\_internal\DeepFaceLab\mainscripts and change line from
output_kwargs.update ({"c:v": "libx265",
to
output_kwargs.update ({"c:v": "libx264",

I think it should work and then convert the sequence to h264 mp4 file. You can edit it with IDLE. I can't test it myself now.
Raising money for a new GPU, if you enjoy my fakes or my work on forums consider donating via bitcoin, tokens or paypal/patreon, any amount helps!
Paypal/Patreon: You are not allowed to view links. Register or Login to view.
Bitcoin: 1C3dq9zF2DhXKeu969EYmP9UTvHobKKNKF
Want to request a paid deepfake or have any questions reagarding the forums or deepfake creation using DeepFaceLab? Write me a message.
TMB-DF on the main website - You are not allowed to view links. Register or Login to view.
#9
Hey thanks for DFL v2, just wanted to know when the guide would be out ? also can i run this on linux ? (i do have a EGPU) so if can make it work i would let you know !
#10
(01-25-2020, 12:57 AM)tutsmybarreh Wrote: You are not allowed to view links. Register or Login to view.
(01-24-2020, 11:56 PM)kilerb Wrote: You are not allowed to view links. Register or Login to view.Anyone else having trouble with the new h265 mp4 exports?  A few issues I've had are that they won't play in Windows, (VLC player works though.)  Maybe a codec download will fix that?  It's asking for money in Windows.  No biggie...  2nd thing is I re-imported the outputted file into Adobe Premiere and it isn't even close to being synced with the audio (However it does play synced in VLC...  So maybe it's another codec issue?)  And the 3rd thing is weird.  I uploaded my outputted video to my google drive like I always do, so I can grab it on my iphone and look at it.  I go to the file and save it (I think these are a bit larger than the h264 files) and it says it's downloading to my iPhone.  Never ends up in my photo album.  Which I've been doing successfully with all previous version of DFL...  Plenty of space on my iPhone.  Not sure if it's because it doesn't recognize it as a video or if it's something else on my end, but like I said, never happened before.  Thanks!

**Edit**  Was just looking again in Premiere.  It works fine at the beginning of the video.  Audio is synced.  Around halfway through it seems to glitch and goes off sync majorly.  It's a 3 minute video btw....  And again, it does play in VLC player fine.  So not sure what's up there.

**Edit 2**  Still playing around on my iPhone.  Google drive has processed the video now, and I can play it in Google drive.  However, I tried again after processing to download it to my phone.  It says "downloading" for a decent amount of time and then stops as usual, but again...  Nothing in my photo/video album.   So weird.

If some site is asking for money for "H265" codec then you are either getting scammed or you got some nice malware on your PC already.

I'll test it later once I train my first fake but not all players can play H265 but most should, same goes for some editing software, it just must be supported.

If you're on PC you can try editing VideoEd file in F:\DF\DFL2.0\_internal\DeepFaceLab\mainscripts and change line from
output_kwargs.update ({"c:v": "libx265",
to
output_kwargs.update ({"c:v": "libx264",

I think it should work and then convert the sequence to h264 mp4 file. You can edit it with IDLE. I can't test it myself now.
I agree that it should play.  But I have 3 computers and all of them need VLC player for 265 files.  I don't think they have viruses.  One of them is really new.  I'll have to investigate more.
  • 1(current)
  • 2
  • 3
  • 4
  • 5
  • ...
  • 14
  • Next 

Forum Jump:

Users browsing this thread: 1 Guest(s)