Mr DeepFakes Forums
  • New and improved dark forum theme!
  • Guests can now comment on videos on the tube.
   
  •  Previous
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • ...
  • 71
  • Next 
DeepFaceLab Explained and Usage Tutorial
#31
(11-05-2018, 05:41 PM)brazilianincel Wrote: You are not allowed to view links. Register or Login to view.tbh i would drop the "clear workspace" bat or put somekind of confirmation, I lost a lot fo work because of lack of attention and running the bat lul

Holy shit me too, I lost a weeks worth of work. I deleted that bat file and just manually clear the folders I need when starting a new project.

(11-06-2018, 10:11 PM)Robin6666 Wrote: You are not allowed to view links. Register or Login to view.I just started using this yesterday and am currently training using the AVATAR model.

I would like to understand why there are different models when we are all trying to do just one thing - swap one face for another with zero imperfections. Is each model better suited to a particular aspect? ie mixed light and dark? a bit blurry? mouth wide open on pornstar but not on celeb? Are any of these things going to be explained to the point where we don't have to ask question?

Q1: can I switch between models to get the, presumably different benefits offered by each (which I don't understand)?

Q2: why are there different models?

Answered your question in your other thread
#32
Im trying to convert and it looks like my PC isnt powerful enough? Wierd that I was able to train for so long. Or is it another problem?
I just kept everything on default settings when converting.
Here is my message:


===== Model summary =====
== Model name: H64
==
== Current epoch: 98980
==
== Options:
== |== batch_size : 2
== |== multi_gpu : False
== |== created_vram_gb : 2.0
== Running on:
== |== [0 : GeForce MX150]
==
== WARNING: You are using 2GB GPU. Result quality may be significantly decreased.
== If training does not start, close all programs and try again.
== Also you can disable Windows Aero Desktop to get extra free VRAM.
==
=========================
2018-11-08 17:33:29.543777: W T:\src\github\tensorflow\tensorflow\core\common_runtime\bfc_allocator.cc:219] Allocator (GPU_0_bfc) ran out of memory trying to allocate 1.14GiB. The caller indicates that this is not a failure, but may mean that there could be performance gains if more memory were available.
Collecting alignments: 100%|███████████████████████████████████████████████████████| 359/359 [00:00<00:00, 2763.01it/s]
Running on CPU0.
Running on CPU1.
Running on CPU2.
Running on CPU3.
Running on CPU4.
Running on CPU5.
Running on CPU6.
Running on CPU7.
Converting: 0it [00:00, ?it/s]
Press any key to continue . . .
#33
(11-08-2018, 07:36 PM)emsbabs Wrote: You are not allowed to view links. Register or Login to view.Im trying to convert and it looks like my PC isnt powerful enough? Wierd that I was able to train for so long. Or is it another problem?
I just kept everything on default settings when converting.
Here is my message:


===== Model summary =====
== Model name: H64
==
== Current epoch: 98980
==
== Options:
== |== batch_size : 2
== |== multi_gpu : False
== |== created_vram_gb : 2.0
== Running on:
== |== [0 : GeForce MX150]
==
== WARNING: You are using 2GB GPU. Result quality may be significantly decreased.
== If training does not start, close all programs and try again.
== Also you can disable Windows Aero Desktop to get extra free VRAM.
==
=========================
2018-11-08 17:33:29.543777: W T:\src\github\tensorflow\tensorflow\core\common_runtime\bfc_allocator.cc:219] Allocator (GPU_0_bfc) ran out of memory trying to allocate 1.14GiB. The caller indicates that this is not a failure, but may mean that there could be performance gains if more memory were available.
Collecting alignments: 100%|███████████████████████████████████████████████████████| 359/359 [00:00<00:00, 2763.01it/s]
Running on CPU0.
Running on CPU1.
Running on CPU2.
Running on CPU3.
Running on CPU4.
Running on CPU5.
Running on CPU6.
Running on CPU7.
Converting: 0it [00:00, ?it/s]
Press any key to continue . . .

Did you try the recommendation of disabling windows Aero? Also maybe try a different resolution to free up more vRAM?
#34
(11-09-2018, 04:14 AM)dpfks Wrote: You are not allowed to view links. Register or Login to view.
(11-08-2018, 07:36 PM)emsbabs Wrote: You are not allowed to view links. Register or Login to view.Im trying to convert and it looks like my PC isnt powerful enough? Wierd that I was able to train for so long. Or is it another problem?
I just kept everything on default settings when converting.
Here is my message:


===== Model summary =====
== Model name: H64
==
== Current epoch: 98980
==
== Options:
== |== batch_size : 2
== |== multi_gpu : False
== |== created_vram_gb : 2.0
== Running on:
== |== [0 : GeForce MX150]
==
== WARNING: You are using 2GB GPU. Result quality may be significantly decreased.
== If training does not start, close all programs and try again.
== Also you can disable Windows Aero Desktop to get extra free VRAM.
==
=========================
2018-11-08 17:33:29.543777: W T:\src\github\tensorflow\tensorflow\core\common_runtime\bfc_allocator.cc:219] Allocator (GPU_0_bfc) ran out of memory trying to allocate 1.14GiB. The caller indicates that this is not a failure, but may mean that there could be performance gains if more memory were available.
Collecting alignments: 100%|███████████████████████████████████████████████████████| 359/359 [00:00<00:00, 2763.01it/s]
Running on CPU0.
Running on CPU1.
Running on CPU2.
Running on CPU3.
Running on CPU4.
Running on CPU5.
Running on CPU6.
Running on CPU7.
Converting: 0it [00:00, ?it/s]
Press any key to continue . . .

Did you try the recommendation of disabling windows Aero? Also maybe try a different resolution to free up more vRAM?
I tried disabling Aero. Didn't work. Can you specify, how to free up some more vRAM?
And which settings when converting requires less vRAM?
#35
(11-08-2018, 07:36 PM)emsbabs Wrote: You are not allowed to view links. Register or Login to view.Im trying to convert and it looks like my PC isnt powerful enough? Wierd that I was able to train for so long. Or is it another problem?
I just kept everything on default settings when converting.
Here is my message:


===== Model summary =====
== Model name: H64
==
== Current epoch: 98980
==
== Options:
== |== batch_size : 2
== |== multi_gpu : False
== |== created_vram_gb : 2.0
== Running on:
== |== [0 : GeForce MX150]
==
== WARNING: You are using 2GB GPU. Result quality may be significantly decreased.
== If training does not start, close all programs and try again.
== Also you can disable Windows Aero Desktop to get extra free VRAM.
==
=========================
2018-11-08 17:33:29.543777: W T:\src\github\tensorflow\tensorflow\core\common_runtime\bfc_allocator.cc:219] Allocator (GPU_0_bfc) ran out of memory trying to allocate 1.14GiB. The caller indicates that this is not a failure, but may mean that there could be performance gains if more memory were available.
Collecting alignments: 100%|███████████████████████████████████████████████████████| 359/359 [00:00<00:00, 2763.01it/s]
Running on CPU0.
Running on CPU1.
Running on CPU2.
Running on CPU3.
Running on CPU4.
Running on CPU5.
Running on CPU6.
Running on CPU7.
Converting: 0it [00:00, ?it/s]
Press any key to continue . . .

I haven't used DeepFaceLab, but if updated nVidia drivers are necessary, new drivers were released the same day you posted this. Just a thought.

Also, if you are using Win10, there is no way to free all your VRAM.  At least I couldn't find a solution, and I've searched *a lot*.  It's a Microsoft issue, they've known about since Win10 was released, and haven't addressed the issue.
#36
Sadly it dint't work with updated drivers either. And sadly as you say @Pocketspeed, freeing more vRAMs isn't quite so possible or effective.
I just have to deal with my PC beeing to weak to do this :-( Thinking of trying a eGPU or keep trying to make the MX150 do the job. Any tips and tricks are more than welcome :-)
And thanks for the help until now!
#37
(11-08-2018, 07:36 PM)emsbabs Wrote: You are not allowed to view links. Register or Login to view.Im trying to convert and it looks like my PC isnt powerful enough? Wierd that I was able to train for so long. Or is it another problem?
I just kept everything on default settings when converting.
Here is my message:


===== Model summary =====
== Model name: H64
==
== Current epoch: 98980
==
== Options:
== |== batch_size : 2
== |== multi_gpu : False
== |== created_vram_gb : 2.0
== Running on:
== |== [0 : GeForce MX150]
==
== WARNING: You are using 2GB GPU. Result quality may be significantly decreased.
== If training does not start, close all programs and try again.
== Also you can disable Windows Aero Desktop to get extra free VRAM.
==
=========================
2018-11-08 17:33:29.543777: W T:\src\github\tensorflow\tensorflow\core\common_runtime\bfc_allocator.cc:219] Allocator (GPU_0_bfc) ran out of memory trying to allocate 1.14GiB. The caller indicates that this is not a failure, but may mean that there could be performance gains if more memory were available.
Collecting alignments: 100%|███████████████████████████████████████████████████████| 359/359 [00:00<00:00, 2763.01it/s]
Running on CPU0.
Running on CPU1.
Running on CPU2.
Running on CPU3.
Running on CPU4.
Running on CPU5.
Running on CPU6.
Running on CPU7.
Converting: 0it [00:00, ?it/s]
Press any key to continue . . .

That doesn't seem to be an out of memory error it seems to have found the aligned directory but not the source frames so it didn't have anything to convert and it exited without any errors.
#38
Oh yes I believe @RandomAnon is right.

So to fix this make sure you have your aligned facesets in the correct directories:

/data_src/aligned
/data_dst/aligned

If you are using a faceset made from somewhere else, you will need to put those images in the correct folder /data_src and /data_dst then run extraction bat. It is weird that you would have this error since you were allowed to train... Did you change directories after training?
#39
My paths are as so:

C:\DeepFaceLab\DeepFaceLab\workspace\data_dst\aligned
C:\DeepFaceLab\DeepFaceLab\workspace\data_src\aligned

I thought it was wierd that I was able to train for almost 15 hours without trouble. It's the training that takes most of the vRAM, right?

After the faces were aligned I deleted the extracted images from data_dst and data_src and also the src_videos and dst_video. Do DFL need the video to be in the folder as well to recreate the sounds in the deepfake?
I also deleted some bad alignments while training and continued training afterwards. But that should course troubles?
#40
(11-10-2018, 01:42 PM)emsbabs Wrote: You are not allowed to view links. Register or Login to view.My paths are as so:

C:\DeepFaceLab\DeepFaceLab\workspace\data_dst\aligned
C:\DeepFaceLab\DeepFaceLab\workspace\data_src\aligned

I thought it was wierd that I was able to train for almost 15 hours without trouble. It's the training that takes most of the vRAM, right?

After the faces were aligned I deleted the extracted images from data_dst and data_src and also the src_videos and dst_video. Do DFL need the video to be in the folder as well to recreate the sounds in the deepfake?
I also deleted some bad alignments while training and continued training afterwards. But that should course troubles?

I'm assuming that DeepFaceLab is somewhat similar to Faceswap. I'm pretty sure you need your frame extractions from data_dst in order to convert. Just extract the images from dst_video again. Leave them in your data_dst folder.  You should not have to align the images again; just leave them where they are. Make sure all your selections and settings are exactly as before you deleted the files. Then, using your trained model, attempt the conversion again.  I would also suggest that you backup copy your model and alignments before doing that, just in case. You will need the video in order to get audio. Deleting bad alignments should be okay.
  •  Previous
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • ...
  • 71
  • Next 

Forum Jump:

Users browsing this thread: 3 Guest(s)