Mr DeepFakes Forums
  • New and improved dark forum theme!
  • Guests can now comment on videos on the tube.
   
danDeepFaceLab: GTX 980 4GB - Anyone had success training H128 ?
#1
Hey All,
I'm new to DeepFaceLab, still experimenting and so far I got nice little tests with the H64 and these settings:


Code:
===== Model summary =====
== Model name: H64
==
== Current epoch: 104803
==
== Model options:
== |== batch_size : 4 (sometimes 8)
== |== sort_by_yaw : False
== |== random_flip : True
== |== lighter_ae : False
== Running on:
== |== [0 : GeForce GTX 980]
=========================

The thing is, that I would like to try H128 but even on Batch size 2 or 4 I get out of memory.
When I Train, I close anything possible (not even a browser is open) and so far I can't get this to work, so I wonder if any of you with GTX 980 actually use some training settings (even if it will be very slow) with the H128 very curious if it is possible with the 4GB (I know it's a really old card... but I'm curious).

My specs:

Intel i7-4770K, 32GB RAM, GTX 980
OS: Windows 10 64bit
Maybe I forget anything else that is important?

I'm still learning as I go, please share your experience if you're using some kind of the same.
Thanks ahead and sorry about my bad English.
#2
Did you turn off windows 10 aero background? Single non-4k screen?
#3
(02-09-2019, 02:17 AM)dan Wrote: You are not allowed to view links. Register or Login to view.Hey All,
I'm new to DeepFaceLab, still experimenting and so far I got nice little tests with the H64 and these settings:


Code:
===== Model summary =====
== Model name: H64
==
== Current epoch: 104803
==
== Model options:
== |== batch_size : 4 (sometimes 8)
== |== sort_by_yaw : False
== |== random_flip : True
== |== lighter_ae : False
== Running on:
== |== [0 : GeForce GTX 980]
=========================

The thing is, that I would like to try H128 but even on Batch size 2 or 4 I get out of memory.
When I Train, I close anything possible (not even a browser is open) and so far I can't get this to work, so I wonder if any of you with GTX 980 actually use some training settings (even if it will be very slow) with the H128 very curious if it is possible with the 4GB (I know it's a really old card... but I'm curious).

My specs:

Intel i7-4770K, 32GB RAM, GTX 980
OS: Windows 10 64bit
Maybe I forget anything else that is important?

I'm still learning as I go, please share your experience if you're using some kind of the same.
Thanks ahead and sorry about my bad English.

Use the light ae and you will be able to run 128 with no problem.
#4
(02-09-2019, 02:31 AM)dpfks Wrote: You are not allowed to view links. Register or Login to view.Did you turn off windows 10 aero background? Single non-4k screen?
OK, this is my very noobish situation, sorry about that:
I thought it was off but I realized that I'm not sure how to check if my Aero is on or off, or how do I turn it off, can you please share a noob screenshot or something?
Google shows me an antique version of Windows 10 the settings are sooo different from what I see here that's why Aero is probably hiding somewhere on the display settings, I'm guessing.

I have 4 monitors each 1080p but I only use 2 monitors (the others are off when using DeepFaceLab).
I didn't realize this will use the RAM so much, I can always turn all and use 1 if it's critical? because I think the log showed me that 3.x GB our of 4GB is free, but still exit out of memory or some error related to this.

Any help will be appreciate since I'm still experimenting.

(02-09-2019, 02:33 AM)easy40 Wrote: You are not allowed to view links. Register or Login to view.Use the light ae and you will be able to run 128 with no problem.

I thought SAE is too insane for my specs.
Any suggested settings to try? will be nice to see it start training without crashing right away Smile

Oh! another question I would like to understand:
The Batch Size, if I use 4 or 8 (can't handle 16 unfortunately) does it mean that it will work slower eventually or will make less accurate results?
I don't mind about the speed (as long as it's not super slow like CPU hehe). so far I use 4 or 8 but most of the time 8 is out of memory after less than a minute or two.

For now, I'm still trying to see how to disable that AERO! it must be hiding somewhere on settings right?
#5
(02-09-2019, 02:40 AM)dan Wrote: You are not allowed to view links. Register or Login to view.
(02-09-2019, 02:31 AM)dpfks Wrote: You are not allowed to view links. Register or Login to view.Did you turn off windows 10 aero background? Single non-4k screen?
OK, this is my very noobish situation, sorry about that:
I thought it was off but I realized that I'm not sure how to check if my Aero is on or off, or how do I turn it off, can you please share a noob screenshot or something?
Google shows me an antique version of Windows 10 the settings are sooo different from what I see here that's why Aero is probably hiding somewhere on the display settings, I'm guessing.

I have 4 monitors each 1080p but I only use 2 monitors (the others are off when using DeepFaceLab).
I didn't realize this will use the RAM so much, I can always turn all and use 1 if it's critical? because I think the log showed me that 3.x GB our of 4GB is free, but still exit out of memory or some error related to this.

Any help will be appreciate since I'm still experimenting.

(02-09-2019, 02:33 AM)easy40 Wrote: You are not allowed to view links. Register or Login to view.Use the light ae and you will be able to run 128 with no problem.

I thought SAE is too insane for my specs.
Any suggested settings to try? will be nice to see it start training without crashing right away :)
I'm taking about the lighter_ae : False option. Set it to true and everything should work.
#6
(02-09-2019, 02:49 AM)easy40 Wrote: You are not allowed to view links. Register or Login to view.I'm taking about the lighter_ae : False option. Set it to true and everything should work.

Ohhh!  I will give it a try, sorry for the confusion I still need to get used to the settings as I experiement.

BTW - Did you try something like that with similar specs? I'm curious if the chance is good to train without crashing for longer than few minutes.
#7
(02-09-2019, 02:54 AM)dan Wrote: You are not allowed to view links. Register or Login to view.
(02-09-2019, 02:49 AM)easy40 Wrote: You are not allowed to view links. Register or Login to view.I'm taking about the lighter_ae : False option. Set it to true and everything should work.

Ohhh!  I will give it a try, sorry for the confusion I still need to get used to the settings as I experiement.

BTW - Did you try something like that with similar specs? I'm curious if the chance is good to train without crashing for longer than few minutes.

Check my latest vids if you want. Done with worse specs than yours.

Forum Jump:

Users browsing this thread: 1 Guest(s)